Sebastian Mogilowskis Blog

Just another blog about administration, linux and other stuff

May, 2011

Install VMware Tools on Debian Squeeze

1. Installation der benötigten Pakete aptitude install autoconf automake binutils cpp gcc linux-headers-$(uname -r) make psmisc 2. VMware Tools einbinden mkdir /tmp/vmtools mount /dev/cdrom /tmp/vmtools 3. Tools entpacken tar -C /tmp -vfx /tmp/vmtools/VMwareTools*.tar.gz 4. Installationsscript starten cd /tmp/vmware-tools-distrib ./vmware-install.pl Bemerkung: Man kann als Alternative zu den VMware Tools auch die “open-vm-tools” installieren. aptitude install open-vm-tools […]

, , ,

Nginx as reverse proxy cache for wordpress and apache

1. Nginx installieren * PPA Installation * Installation mit selbstgebauten Paket 2. Allgemeine Nginx Einstellungen Folgende Einstellungen in der Datei “/etc/nginx/nginx.conf” vornehmen: […] http { […] # Gzip Settings gzip on; gzip_disable “msie6”; gzip_buffers 32 8k; gzip_comp_level 6; gzip_http_version 1.0; gzip_min_length 0; gzip_types text/html text/css image/x-icon application/x-javascript application/javascript text/javascript application/atom+xml application/xml ; # Proxy Settings […]

, , , , ,

Install nginx on debian squeeze from PPA

Aktuell findet man die Version 0.7.67-3 von Nginx in Debian Squeeze. Wenn man eine neuere Version haben möchte, kann man sich seine eigenen Pakete bauen, oder man verwendet welche aus den Ubuntu PPA-Quellen. Dies installiert die neuste (stable) Version von Nginx (aktuell 1.0.1) auf Debian Squeeze. echo “deb http://ppa.launchpad.net/nginx/stable/ubuntu lucid main” > /etc/apt/sources.list.d/nginx-stable-lucid.list apt-key adv […]

, , ,

Building a nginx debian package with third party modules

Ich habe diese Anleitung mit Debian Squeeze (amd64) und der neusten Version von Nginx (stable) mit einem Third Party Module als Beispiel erstellt. Bitte beachtet, das ihr ggf. die Versionsnummern in dieser Anleitung anpassen müsst, wenn ihr neuere Versionen von Nginx oder des Moduls verwendet. 1. Installation Debian Build-Tools und abhängigen Paketen aptitude install build-essential […]

, ,