Sebastian Mogilowskis Blog

Just another blog about administration, linux and other stuff

Fixing broken Thecus N8800PRO NAS or install Linux on Thecus N8880PRO NAS

A few days ago one of my old Thecus N8800PRO NAS storages stopped working. Instead of throwing it away i decided to take a closer look at it.

First i discovered the missing VGA Port on the system. So no way for more debugging.

But if open the NAS and take a closer look to the mainboard you see that Thecus just “forgot” to put the VGA Port on the Mainboard.
It would be too much work to solder one on the board if you just want to know what’s exactly broken. So i just killed one of the many many VGA Cables we collected over the years. I removed the metall shield from one side with electronic pilers and directly connect it with the mainboard.

thecus1 thecus2

Here we go … VGA Output from the NAS system. Not a very beautiful solution but it works 😉

thecus3

The many many error messages told me that this little thing was broken.

thecus4

It is an IDE Flash storage stack of two 128MB Flash Modules (IDE Master and Slave) for the thecus operating system.
This are 40-Pin IDE Flash Modules and i quick ordered one online. I choose a cheap 2GB module to have enough space for the new system. Openmediavault needs a little bit more than 1GB after a fresh installation.

thecus5

With an USB stick i installed OpenMediaVault http://www.openmediavault.org on the Thecus.

But you can install every other linux oder nas distribution you like.

Now you had a new storage system with an fresh linux and fresh software instead of the old Thecus software which had no update for “decades”.

thecus6

Leave a Reply

Your email address will not be published. Required fields are marked *

eMail-Benachrichtigung bei weiteren Kommentaren.
Auch möglich: Abo ohne Kommentar.